Posts: 1
Joined: Fri Jun 24, 2016 9:35 am

HiDPI Displays

Fri Jun 24, 2016 9:42 am

So I tried out Solus using a live USB stick on my laptop, and as expected Gnome and smaller(14") WQHD (2560x1440) screens do not agree. Everything was scaled too big, and I had almost no screen real estate to work with.

There are some options when battling this. You can open up the Tweak Tool and fiddle with Window and Font scaling factors.

What I do is leave the defaults and use this little trick I have found on the Arch Wiki.

Will paste the commands below:

Code: Select all

# First scale Gnome up to the minimum size which is too big.
# Usually "2" is already too big, but if "2" is still small for you, try "3", etc.
gsettings set org.gnome.desktop.interface scaling-factor 2
# Now start scaling down by setting zoom-out factor with xrandr.
# First get the output name:
xrandr | grep -v disconnected | grep connected | cut -d' ' -f1
# eDP1
# Use this value to specify --output further on.
# If you have two or more screens you can set their scale independently.
# Now, to zoom-out 1.2 times, run the following:
xrandr --output eDP1 --scale 1.2x1.2
# If the UI is still too big, increase the scale:
xrandr --output eDP1 --scale 1.25x1.25
# If UI becomes too small, decrease the scale factor a bit.
# Repeat until you find a value which works best for your screen and your eyes.
# Finally, you need to allow the mouse to navigate the whole screen.
# To do this you need to get the current scaled resolution:
xrandr | grep eDP1
# eDP1 connected primary 2304x1296+0+0 (normal left inverted right x axis y axis) 239mm x 134mm
# Now use the acquired resolution value to set correct panning:
xrandr --output eDP1 --panning 2304x1296
If anyone has other ideas on how to set up scaling nicely let me know.

Posts: 4
Joined: Tue Feb 20, 2018 11:45 am

Re: HiDPI Displays

Sun Mar 18, 2018 12:05 pm

Hi, I am having the opposite situation. I feel things are too small in my screen (1920x1080). However, it's very nice on my external monitor. I don't know how to scale out in my built-in screen. I have tried to scale out the font with tweaks tool. But it only scale out the system font. in Firefox things are still small. Maybe, I should try what you posted above.

User avatar
Posts: 48
Joined: Mon Mar 05, 2018 10:05 pm
Location: France

Re: HiDPI Displays

Sun Mar 18, 2018 2:01 pm

Try this https://www.pcworld.com/article/2911509 ... plays.html

you don't have to put whole numbers, for Firefox ( layout.css.devPixelsPerPx ) I put 1.20 & it's good for me on 32" WQHD (2560x1440)

Otherwise try to play on the font sizes in the general parameters.

Posts: 4
Joined: Sun Aug 14, 2016 9:45 pm

Re: HiDPI Displays

Mon Mar 19, 2018 7:07 pm

Install Gnome Tweak Tool.
In Display Settings, set display scaling to 100%.
In Gnome Tweak Tool, go to the Fonts tab.
Set Font Scaling to between 1.25 and 1.5. 1.45 seems to be "just right," where I can have both a terminal window and Firefox open without alt-tabbing.

Return to “Tutorials”