User avatar
alexanderzhirov
Posts: 30
Joined: Fri Dec 07, 2018 10:25 pm
Contact: Website

[SOLVED] crashed when setting up DeadBeef

Sat Jan 12, 2019 5:18 pm

When you select "Group by" DeadBeef crashes and closes. DeadBeef is installed from the repository.

Code: Select all

$ deadbeef --version
starting deadbeef devel
DeaDBeeF devel Copyright © 2009-2017 Alexey Yakovenko
It is strange that the development version of DeadBeef is used. Maybe in the latest versions of these problems are fixed.
hm... Why is the devel version installed when you install a non-devel package? :?

User avatar
kyrios
Posts: 2580
Joined: Thu Sep 22, 2016 4:20 pm

Re: crashed when setting up DeadBeef

Sat Jan 12, 2019 6:36 pm

alexanderzhirov wrote:
Sat Jan 12, 2019 5:18 pm
When you select "Group by" DeadBeef crashes and closes. DeadBeef is installed from the repository.

Code: Select all

$ deadbeef --version
starting deadbeef devel
DeaDBeeF devel Copyright © 2009-2017 Alexey Yakovenko
It is strange that the development version of DeadBeef is used. Maybe in the latest versions of these problems are fixed.
hm... Why is the devel version installed when you install a non-devel package? :?

You can check the changelogs from the software center or from the dev-tracker to find the answer : https://dev.getsol.us/R607:c325f543c6c0 ... 10087ea65c
Troubleshooting Guide | Package Requests / Update | Bug Tracker
I don't read private messages

User avatar
alexanderzhirov
Posts: 30
Joined: Fri Dec 07, 2018 10:25 pm
Contact: Website

Re: crashed when setting up DeadBeef

Sun Jan 13, 2019 10:51 am

I'm sorry, but I'm stupid. I don't understand what I have to do. I downloaded DeadBeef from the package Manager. Run the program. I begin to configure it and when you configure my program is closed. Why is this happening - I can not understand. But I have an assumption that the version of the player does not match the latest version on the official website. Tell me, what do I need to do to find a mistake? How to track the moment of closing the program? Where to find logs?

User avatar
kyrios
Posts: 2580
Joined: Thu Sep 22, 2016 4:20 pm

Re: crashed when setting up DeadBeef

Sun Jan 13, 2019 11:41 am

alexanderzhirov wrote:
Sun Jan 13, 2019 10:51 am
I'm sorry, but I'm stupid. I don't understand what I have to do. I downloaded DeadBeef from the package Manager. Run the program. I begin to configure it and when you configure my program is closed. Why is this happening - I can not understand. But I have an assumption that the version of the player does not match the latest version on the official website. Tell me, what do I need to do to find a mistake? How to track the moment of closing the program? Where to find logs?

If the application crashes, you have to report the issue on the bug tracker and ideally first check upstream if the problem was already reported.

You asked why the devel version is used and I did point you a commit that explains why : "Move to a later git to resolve T6285." And if you look at T6285, you will see
Deadbeef using 100% CPU when playing music.
Found the issue on GitHub as well. DeaDBeeF Issue #1927
Can you guys fix it?

In Solus IRC Ikey ask for the commit hash, which one have I run without the CPU load issue.
It is the current latest: 24feac8 (24feac8bec6505e306d192eaa15f72717fdddd4c).

Thank you for your help!


So basically the same will have to be done to address your issue. The problem is you asked multiple things in your message and I did only answer one of them, sorry about this.
Troubleshooting Guide | Package Requests / Update | Bug Tracker
I don't read private messages

User avatar
alexanderzhirov
Posts: 30
Joined: Fri Dec 07, 2018 10:25 pm
Contact: Website

Re: crashed when setting up DeadBeef

Sun Jan 13, 2019 11:55 am

It turns out that the problem is fixed. I see here. And the Solus repository doesn't have this fix, right? You'll excuse me, I'm not really good at developing websites. I just don't understand what I need to do to report a bug or fix it somehow. I'm just trying to get into the development movement and learn everything from the beginning.

User avatar
kyrios
Posts: 2580
Joined: Thu Sep 22, 2016 4:20 pm

Re: crashed when setting up DeadBeef

Sun Jan 13, 2019 12:41 pm

alexanderzhirov wrote:
Sun Jan 13, 2019 11:55 am
It turns out that the problem is fixed. I see here. And the Solus repository doesn't have this fix, right? You'll excuse me, I'm not really good at developing websites. I just don't understand what I need to do to report a bug or fix it somehow. I'm just trying to get into the development movement and learn everything from the beginning.

I know the issue is fixed since I did point this out, right? (sorry for quote myself) :
kyrios wrote:
Sun Jan 13, 2019 11:41 am
If the application crashes, you have to report the issue on the bug tracker and ideally first check upstream if the problem was already reported.

So basically you don't really care to know why a development version is used instead of the official 0.7.2 tarball? (so why did you focus on that in your original post?).
What you actually want is to have this issue fixed on Solus, right? You don't really care to know why a development version is used instead of the official 0.7.2 tarball? If so just open a new task on the bug tracker to report this very specific problem instead of doing a mix of different things that confuse everyone (including yourself obviously).

Here are a few recommendations that may help you to get straight to the point:
- Forums & social medias are an area for the community for talking, helping each others, sharing things, etc.
- If you ask multiple things together, you may only get answer to some of the points (because the person who will reply only know the answer to some of the questions, doesn't pay attention, is only interested by some of your topics, doesn't have time to reply to everything or whatever reason).
- Bugs should be reported on the bug tracker (not on forums, social medias, etc.. unless you are looking for help of the community. For example when you're not sure if a problem is a configuration issue or a bug in the software).
. One bug = 1 task, never mix multiple things into a single task on the bug tracker.
Troubleshooting Guide | Package Requests / Update | Bug Tracker
I don't read private messages

User avatar
alexanderzhirov
Posts: 30
Joined: Fri Dec 07, 2018 10:25 pm
Contact: Website

Re: crashed when setting up DeadBeef

Sun Jan 13, 2019 2:52 pm

A... I beg your pardon. That's not how I put it. I have problems with English, so I have to use a translator.

I thought that the Solus repository contains a package that is available on the official DeadBeef player development site. If I understand you correctly, there is a version in the Solus repository that is supported by the Solus developers, right? Please excuse me if I didn't put it that way. Using DeadBeef earlier in another distribution I did not face such a problem that I have now. So I decided to ask here on the forum.

Should I make a request thread about this issue on the site?

User avatar
Harvey
Posts: 16
Joined: Mon Apr 10, 2017 4:26 am
Location: Sydney/Australia

Re: crashed when setting up DeadBeef

Sun Jan 13, 2019 3:18 pm

alexanderzhirov wrote: I thought that the Solus repository contains a package that is available on the official DeadBeef player development site. If I understand you correctly, there is a version in the Solus repository that is supported by the Solus developers, right?
The whos wheres an whys are not really important to a resolution which is the point I think Kyrios is making. But my understanding is that for whatever reason deadbeef continues to be developed but they haven't tagged a new release since 2016 so they have to pull from git master to get fixes. Because of them not tagging releases its hard to know when something should be updated and what has been fixed.

But as I said, none of that is really important to you. You need to file a bug report.

Example of a bug report I would file to https://dev.getsol.us/maniphest/task/edit/form/1/
{ Title section }
DeadBeef crashes when you select "group by"

{ Description section: }
When you select "Group by" DeadBeef crashes.
{ Provide exact details of how it can be reproduced, I don't use deadbeef for example so I wouldn't know where to find "group by" }

This is a known bug and has been resolved:
https://github.com/DeaDBeeF-Player/deadbeef/issues/2042
At least that's what I would do.

User avatar
alexanderzhirov
Posts: 30
Joined: Fri Dec 07, 2018 10:25 pm
Contact: Website

Re: crashed when setting up DeadBeef

Tue Jan 15, 2019 10:07 pm

I created request about this error https://dev.getsol.us/T7500

User avatar
alexanderzhirov
Posts: 30
Joined: Fri Dec 07, 2018 10:25 pm
Contact: Website

Re: crashed when setting up DeadBeef

Fri Jan 18, 2019 3:44 pm

Today there was an update that fixed my problem! Thank you!!! :)
Image

Return to “Other Questions”