zenkan
Posts: 1
Joined: Thu Aug 16, 2018 9:36 am

How do i turn off edns in solus

Thu Aug 16, 2018 9:46 am

So I'm at a customer with my laptop, a Solus machine, and I can't access their local infrastructure via their DNS server. After some digging, I found that dig server1.customer.local gets a FORMERR status from the server. If I, however, add the flag +noedns to my dig query (dig +noedns server1.customer.local) I get a proper response.

My assumption is that the EDNS feature is enabled by default in Solus but is not supported by the customers DNS server. Is it possible to disable this feature in the operating system so that I can access their local infrastructure?

Return to “Other Questions”