User avatar
BradHeff
Posts: 55
Joined: Sun Mar 20, 2016 2:14 am
Location: Adelaide, Australia

Budgie Weather applet

Mon Dec 04, 2017 7:01 am

i found this for budgie desktop is there any way to implement it in current version, having dependency issues here is the GitHub i found https://github.com/ilgarmehmetali/budgie-weather-applet

the weather program from the software center doesnt seem to work on the budgie desktop version im getting this error

Code: Select all

/usr/bin/gjs: error while loading shared libraries: libmozjs-52.so.0: cannot open shared object file: No such file or directory
Image

User avatar
kyrios
Posts: 2286
Joined: Thu Sep 22, 2016 4:20 pm

Re: Budgie Weather applet

Mon Dec 04, 2017 9:36 am

BradHeff wrote:
Mon Dec 04, 2017 7:01 am
i found this for budgie desktop is there any way to implement it in current version, having dependency issues here is the GitHub i found https://github.com/ilgarmehmetali/budgie-weather-applet

the weather program from the software center doesnt seem to work on the budgie desktop version im getting this error

Code: Select all

/usr/bin/gjs: error while loading shared libraries: libmozjs-52.so.0: cannot open shared object file: No such file or directory
This applet is not yet ready for production. As you can see there is just one pre-release at the moment.

User avatar
BradHeff
Posts: 55
Joined: Sun Mar 20, 2016 2:14 am
Location: Adelaide, Australia

Re: Budgie Weather applet

Thu Dec 07, 2017 11:13 pm

Found another that works well, only shows a cloud icon not temp along side but on hover it displays current weather and on clicking of the icon displays the next 4 days so its better than nothing i guess :D
the installation instructions and setup are found here.

Code: Select all

http://entornosgnulinux.com/2016/05/21/minimalist-weather-indicator-en-solus-1-1/
Image

User avatar
ycrawler
Posts: 152
Joined: Thu Aug 10, 2017 8:23 pm

Re: Budgie Weather applet

Thu Dec 07, 2017 11:26 pm

i cant get gnome-weather or gnome-maps to work because of missing libmozjs-52.so.0 as well, is that just me?

User avatar
BradHeff
Posts: 55
Joined: Sun Mar 20, 2016 2:14 am
Location: Adelaide, Australia

Re: Budgie Weather applet

Fri Dec 08, 2017 2:24 am

ycrawler wrote:
Thu Dec 07, 2017 11:26 pm
i cant get gnome-weather or gnome-maps to work because of missing libmozjs-52.so.0 as well, is that just me?
no not just you i cant get the gnome-weather to work havent tried maps thats why im using an applet.
Image

User avatar
ycrawler
Posts: 152
Joined: Thu Aug 10, 2017 8:23 pm

Re: Budgie Weather applet

Fri Dec 08, 2017 7:11 pm

mozjs was installed during todays update. gnome-weather, gnome-maps work again, and probably the weather app mentioned in the first post as well

Return to “Ideas”