Metta
Posts: 5
Joined: Tue Dec 12, 2017 2:03 am

Re: [SOLVED] Live CD == black screen [MBP 9,1 -- mid-2012 -- A1286]

Tue Dec 12, 2017 3:22 am

Thanks, I was able to bring up Solus 3 on MBP 5,1 (which there is no High Sierra for, so it's the end of the road for OS X on it).

It was not perfectly clear at first to hit 'e' on the Solus prompt with the 3 second countdown but I figured it out. I had only seen Lilo and GRUB for Linux before.

I did not install nvidia-glx-driver for when I tried in live mode I got the black screen of death. Just using 'modprobe -r nouveau' and 'modprobe i915' to bring up live mode to run the installer.

After installing to the hard disk, to get Xorg/budgie working I used:

ctrl-option-F1 for text console then

Code: Select all

sudo -i
mkdir /etc/modprobe.d
echo 'blacklist nouveau' > /etc/modprobe.d/blacklist-nouveau.conf
echo 'i915' > /etc/modules-load.d/i915.conf
systemctl reboot
I still need to get WiFi going. Before I nuked OS X I ran system-profiler so I have:

Code: Select all

Wi-Fi:

      Software Versions:
          CoreWLAN: 11.0 (1101.20)
          CoreWLANKit: 11.0 (1101.20)
          Menu Extra: 11.0 (1121.34.2)
          System Information: 12.0 (1100.2)
          IO80211 Family: 11.1 (1110.26)
          Diagnostics: 5.1 (510.88)
          AirPort Utility: 6.3.6 (636.5)
          
       Interfaces:
        en1:
          Card Type: AirPort Extreme  (0x14E4, 0x8D)
          Firmware Version: Broadcom BCM43xx 1.0 (5.106.98.102.30)
          MAC Address: 00:23:6c:xx:yy:zz
          Locale: FCC
          Country Code: X0
          Supported PHY Modes: 802.11 a/b/g/n
          Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165
          Wake On Wireless: Supported
          AirDrop: Supported
          Status: Off

Code: Select all

lspci -nn | grep Wireless
04:00.0 Network controller [0280]: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

Metta
Posts: 5
Joined: Tue Dec 12, 2017 2:03 am

Re: [SOLVED] Live CD == black screen [MBP 9,1 -- mid-2012 -- A1286]

Fri Dec 15, 2017 1:10 am

WiFi is up:

Code: Select all

sudo -i
eopkg install broadcom-sta-current 
echo 'install wl /sbin/modprobe cfg80211; /sbin/insmod /lib/modules/$(/bin/uname -r)/kernel/drivers/net/wireless/wl.ko' > /etc/modprobe.d/wl.conf 
echo wl > /etc/modules-load.d/wl.conf 
modprobe wl
exit

Cactusron
Posts: 1
Joined: Fri May 25, 2018 5:36 am

Re: [SOLVED] Live CD == black screen [MBP 9,1 -- mid-2012 -- A1286]

Fri May 25, 2018 5:39 am

Metta,

Solus Noob here. Wanted to thank you for the post. Worked great for my old Dell 9020 that I installed a tp-Link AC1300. Worked great immediatly.

Thanks very much again.

Cactusron

Return to “Installation”