echis
Posts: 9
Joined: Sat Dec 09, 2017 11:09 pm

[SOLVED] Not detecting native resolution options

Thu Dec 14, 2017 7:17 pm

Display settings only allow 800x600. Native resolution of display is 1920x1080. Is there an easy way to fix this? :)

inxi -F:

Code: Select all

System:    Host: zenbook Kernel: 4.14.5-39.current x86_64 bits: 64
           Desktop: Budgie 10.4  Distro: Solus 3
Machine:   Device: laptop System: ASUSTeK product: UX305UA v: 1.0 serial: N/A
           Mobo: ASUSTeK model: UX305UA v: 1.0 serial: N/A
           UEFI: American Megatrends v: UX305UA.201 date: 10/12/2015
Battery    BAT0: charge: 11.1 Wh 22.6% condition: 49.1/56.0 Wh (88%)
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2800 MHz 1: 2400 MHz 2: 2400 MHz 3: 2400 MHz
           4: 2400 MHz
Graphics:  Card: Intel Skylake GT2 [HD Graphics 520]
           Display Server: x11 (X.Org 1.19.5 )
           drivers: fbdev (unloaded: modesetting,vesa)
           Resolution: 800x600@75.00hz
           OpenGL: renderer: llvmpipe (LLVM 5.0, 256 bits)
           version: 3.3 Mesa 17.3.0
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.14.5-39.current
Network:   Card: Intel Wireless 7265 driver: iwlwifi
           IF: wlp2s0 state: up mac: 4c:34:88:e7:3e:f7
Drives:    HDD Total Size: 318.0GB (1.7% used)
           ID-1: /dev/sda model: Micron_M600_MTFD size: 256.1GB
           ID-2: USB /dev/sdb model: Voyager_VEGA size: 62.0GB
Partition: ID-1: / size: 117G used: 5.2G (5%) fs: ext4 dev: /dev/sda3
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 167 Uptime: 5 min Memory: 759.2/7948.8MB
           Client: Shell (bash) inxi: 2.3.38
xrandr:

Code: Select all

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected primary 800x600+0+0 0mm x 0mm
   800x600       75.00*
Last edited by echis on Wed Dec 20, 2017 8:03 pm, edited 1 time in total.

User avatar
Justin
Development Team
Posts: 3618
Joined: Mon Jul 28, 2014 10:42 am
Location: Adelaide, Australia
Contact: Website Google+ Twitter

Re: Not detecting native resolution options

Sun Dec 17, 2017 4:10 am

Try installing xorg-driver-video-intel and reboot.

echis
Posts: 9
Joined: Sat Dec 09, 2017 11:09 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 11:06 am

Hi Justin. Thank you for your reply. I have followed your instructions, but unfortunately the issue does not seem to be resolved.
inxi -G now returns the following:

Code: Select all

Graphics:  Card: Intel Skylake GT2 [HD Graphics 520]
           Display Server: x11 (X.Org 1.19.5 )
           drivers: fbdev, intel (unloaded: modesetting,vesa)
           Resolution: 800x600@75.00hz
           OpenGL: renderer: llvmpipe (LLVM 5.0, 256 bits)
           version: 3.3 Mesa 17.3.0
intel is now listed under drivers, alongside fbdev.

xrandr return is the same as before.



Not sure if this is helpful or relevant in any way, but here is the return from the same commands in Mint 18.3 Cinnamon running on a different partition on the same system:
inxi -G:

Code: Select all

Graphics:  Card: Intel Sky Lake Integrated Graphics
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.05hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7
fbdev listed as "unloaded" here. Is that relevant?

xrandr:

Code: Select all

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1920x1080     60.05*+  59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1368x768      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   640x360       60.00  
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
I'm quite new to Linux in general (dabbled with a couple of distros through VirualBox on a Windows host for a couple of months), so please bear with me. If there is any other information you need me to dig up or commands you need me to run, fire away.

Once again, thank you for taking the time.

User avatar
KerfufflyKitty
Posts: 40
Joined: Sat Dec 16, 2017 11:56 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 12:12 pm

echis wrote:
Sun Dec 17, 2017 11:06 am

Code: Select all

           drivers: fbdev, intel (unloaded: modesetting,vesa)
           OpenGL: renderer: llvmpipe (LLVM 5.0, 256 bits)

The Intel driver is still not actually used, so the system is still falling back to the llvmpipe software rasterizer.

Can you post the contents of your /var/log/Xorg.0.log file?

echis
Posts: 9
Joined: Sat Dec 09, 2017 11:09 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 12:43 pm

Absolutely.
Here it is:


[ 2.377]
X.Org X Server 1.19.5
Release Date: 2017-10-12
[ 2.377] X Protocol Version 11, Revision 0
[ 2.378] Build Operating System: Linux 4.10.0-37-generic x86_64
[ 2.378] Current Operating System: Linux zenbook 4.14.6-40.current #1 SMP Sat Dec 16 15:59:08 UTC 2017 x86_64
[ 2.378] Kernel command line: initrd=\EFI\com.solus-project\initrd-com.solus-project.current.4.14.6-40 root=PARTUUID=e2382bbb-4bf7-49e0-8134-4abbf4cf1a71 quiet loglevel=3 splash systemd.show_status=false rw radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 nomodeset resume=UUID=ed6199c1-a21c-403c-b73f-f898ff86925a
[ 2.378] Build Date: 10 December 2017 06:53:03PM
[ 2.378]
[ 2.378] Current version of pixman: 0.34.0
[ 2.378] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 2.378] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 2.378] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 17 12:32:47 2017
[ 2.384] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 2.384] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 2.386] (==) No Layout section. Using the first Screen section.
[ 2.386] (==) No screen section available. Using defaults.
[ 2.386] (**) |-->Screen "Default Screen Section" (0)
[ 2.386] (**) | |-->Monitor "<default monitor>"
[ 2.387] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 2.387] (==) Automatically adding devices
[ 2.387] (==) Automatically enabling devices
[ 2.387] (==) Automatically adding GPU devices
[ 2.387] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 2.389] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[ 2.389] Entry deleted from font path.
[ 2.389] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 2.389] Entry deleted from font path.
[ 2.389] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 2.389] Entry deleted from font path.
[ 2.389] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 2.389] Entry deleted from font path.
[ 2.389] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[ 2.389] Entry deleted from font path.
[ 2.389] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[ 2.389] Entry deleted from font path.
[ 2.389] (==) FontPath set to:

[ 2.389] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 2.389] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 2.389] (II) Loader magic: 0x629d40
[ 2.389] (II) Module ABI versions:
[ 2.389] X.Org ANSI C Emulation: 0.4
[ 2.389] X.Org Video Driver: 23.0
[ 2.389] X.Org XInput driver : 24.1
[ 2.389] X.Org Server Extension : 10.0
[ 2.394] (++) using VT number 7

[ 2.394] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 2.399] (--) PCI:*(0:0:2:0) 8086:1916:1043:1000 rev 7, Mem @ 0xde000000/16777216, 0xc0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[ 2.399] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 2.399] (II) LoadModule: "glx"
[ 2.405] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 2.422] (II) Module glx: vendor="X.Org Foundation"
[ 2.422] compiled for 1.19.5, module version = 1.0.0
[ 2.422] ABI class: X.Org Server Extension, version 10.0
[ 2.422] (==) Matched intel as autoconfigured driver 0
[ 2.422] (==) Matched modesetting as autoconfigured driver 1
[ 2.422] (==) Matched fbdev as autoconfigured driver 2
[ 2.422] (==) Matched vesa as autoconfigured driver 3
[ 2.422] (==) Assigned the driver to the xf86ConfigLayout
[ 2.422] (II) LoadModule: "intel"
[ 2.422] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[ 2.425] (II) Module intel: vendor="X.Org Foundation"
[ 2.425] compiled for 1.19.5, module version = 2.99.917
[ 2.425] Module class: X.Org Video Driver
[ 2.425] ABI class: X.Org Video Driver, version 23.0
[ 2.425] (II) LoadModule: "modesetting"
[ 2.426] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 2.428] (II) Module modesetting: vendor="X.Org Foundation"
[ 2.428] compiled for 1.19.5, module version = 1.19.5
[ 2.428] Module class: X.Org Video Driver
[ 2.428] ABI class: X.Org Video Driver, version 23.0
[ 2.428] (II) LoadModule: "fbdev"
[ 2.429] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 2.429] (II) Module fbdev: vendor="X.Org Foundation"
[ 2.429] compiled for 1.19.5, module version = 0.4.4
[ 2.429] Module class: X.Org Video Driver
[ 2.429] ABI class: X.Org Video Driver, version 23.0
[ 2.429] (II) LoadModule: "vesa"
[ 2.430] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 2.430] (II) Module vesa: vendor="X.Org Foundation"
[ 2.430] compiled for 1.19.5, module version = 2.3.4
[ 2.430] Module class: X.Org Video Driver
[ 2.430] ABI class: X.Org Video Driver, version 23.0
[ 2.430] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 2.431] (II) intel: Driver for Intel(R) HD Graphics
[ 2.431] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[ 2.431] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[ 2.431] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 2.431] (II) FBDEV: driver for framebuffer: fbdev
[ 2.431] (II) VESA: driver for VESA chipsets: vesa
[ 4.490] intel: waited 2020 ms for i915.ko driver to load
[ 4.495] (EE) open /dev/dri/card0: No such file or directory
[ 4.495] (WW) Falling back to old probe method for modesetting
[ 4.495] (EE) open /dev/dri/card0: No such file or directory
[ 4.495] (II) Loading sub module "fbdevhw"
[ 4.495] (II) LoadModule: "fbdevhw"
[ 4.496] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 4.497] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 4.497] compiled for 1.19.5, module version = 0.0.2
[ 4.497] ABI class: X.Org Video Driver, version 23.0
[ 4.497] (**) FBDEV(1): claimed PCI slot 0@0:2:0
[ 4.497] (II) FBDEV(1): using default device
[ 4.497] (WW) Falling back to old probe method for vesa
[ 4.497] (EE) Screen 0 deleted because of no matching config section.
[ 4.497] (II) UnloadModule: "modesetting"
[ 4.497] (II) FBDEV(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 4.497] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[ 4.497] (==) FBDEV(0): RGB weight 888
[ 4.497] (==) FBDEV(0): Default visual is TrueColor
[ 4.497] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[ 4.497] (II) FBDEV(0): hardware: EFI VGA (video memory: 1876kB)
[ 4.497] (II) FBDEV(0): checking modes against framebuffer device...
[ 4.498] (II) FBDEV(0): checking modes against monitor...
[ 4.498] (--) FBDEV(0): Virtual size is 800x600 (pitch 800)
[ 4.498] (**) FBDEV(0): Built-in mode "current": 48.0 MHz, 46.9 kHz, 75.1 Hz
[ 4.498] (II) FBDEV(0): Modeline "current"x0.0 48.00 800 832 928 1024 600 604 608 624 -hsync -vsync -csync (46.9 kHz b)
[ 4.498] (==) FBDEV(0): DPI set to (96, 96)
[ 4.498] (II) Loading sub module "fb"
[ 4.498] (II) LoadModule: "fb"
[ 4.498] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 4.501] (II) Module fb: vendor="X.Org Foundation"
[ 4.501] compiled for 1.19.5, module version = 1.0.0
[ 4.501] ABI class: X.Org ANSI C Emulation, version 0.4
[ 4.501] (**) FBDEV(0): using shadow framebuffer
[ 4.501] (II) Loading sub module "shadow"
[ 4.501] (II) LoadModule: "shadow"
[ 4.501] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 4.502] (II) Module shadow: vendor="X.Org Foundation"
[ 4.502] compiled for 1.19.5, module version = 1.1.0
[ 4.502] ABI class: X.Org ANSI C Emulation, version 0.4
[ 4.502] (II) UnloadModule: "vesa"
[ 4.502] (II) Unloading vesa
[ 4.502] (==) Depth 24 pixmap format is 32 bpp
[ 4.502] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by kernel - disabling)
[ 4.505] (==) FBDEV(0): Backing store enabled
[ 4.507] (==) FBDEV(0): DPMS enabled
[ 4.507] (==) RandR enabled
[ 4.520] (II) AIGLX: Screen 0 is not DRI2 capable
[ 4.520] (EE) AIGLX: reverting to software rendering
[ 4.643] (II) IGLX: enabled GLX_MESA_copy_sub_buffer
[ 4.644] (II) IGLX: Loaded and initialized swrast
[ 4.644] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[ 4.681] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[ 4.681] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[ 4.681] (**) Power Button: Applying InputClass "system-keyboard"
[ 4.681] (II) LoadModule: "libinput"
[ 4.681] (II) Loading /usr/lib64/xorg/modules/input/libinput_drv.so
[ 4.685] (II) Module libinput: vendor="X.Org Foundation"
[ 4.685] compiled for 1.19.5, module version = 0.26.0
[ 4.685] Module class: X.Org XInput Driver
[ 4.685] ABI class: X.Org XInput driver, version 24.1
[ 4.685] (II) Using input driver 'libinput' for 'Power Button'
[ 4.685] (**) Power Button: always reports core events
[ 4.685] (**) Option "Device" "/dev/input/event4"
[ 4.686] (**) Option "_source" "server/udev"
[ 4.686] (II) event4 - (II) Power Button: (II) is tagged by udev as: Keyboard
[ 4.686] (II) event4 - (II) Power Button: (II) device is a keyboard
[ 4.686] (II) event4 - (II) Power Button: (II) device removed
[ 4.699] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event4"
[ 4.699] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 4.699] (**) Option "xkb_model" "pc104"
[ 4.699] (**) Option "xkb_layout" "no"
[ 4.717] (II) event4 - (II) Power Button: (II) is tagged by udev as: Keyboard
[ 4.717] (II) event4 - (II) Power Button: (II) device is a keyboard
[ 4.717] (II) config/udev: Adding input device Asus Wireless Radio Control (/dev/input/event2)
[ 4.717] (**) Asus Wireless Radio Control: Applying InputClass "libinput keyboard catchall"
[ 4.717] (**) Asus Wireless Radio Control: Applying InputClass "system-keyboard"
[ 4.717] (II) Using input driver 'libinput' for 'Asus Wireless Radio Control'
[ 4.717] (**) Asus Wireless Radio Control: always reports core events
[ 4.717] (**) Option "Device" "/dev/input/event2"
[ 4.717] (**) Option "_source" "server/udev"
[ 4.718] (II) event2 - (II) Asus Wireless Radio Control: (II) is tagged by udev as: Keyboard
[ 4.718] (II) event2 - (II) Asus Wireless Radio Control: (II) device is a keyboard
[ 4.718] (II) event2 - (II) Asus Wireless Radio Control: (II) device removed
[ 4.747] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/ATK4002:00/input/input2/event2"
[ 4.747] (II) XINPUT: Adding extended input device "Asus Wireless Radio Control" (type: KEYBOARD, id 7)
[ 4.747] (**) Option "xkb_model" "pc104"
[ 4.747] (**) Option "xkb_layout" "no"
[ 4.747] (II) event2 - (II) Asus Wireless Radio Control: (II) is tagged by udev as: Keyboard
[ 4.747] (II) event2 - (II) Asus Wireless Radio Control: (II) device is a keyboard
[ 4.748] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[ 4.748] (II) No input driver specified, ignoring this device.
[ 4.748] (II) This device may have been added with another device file.
[ 4.749] (II) config/udev: Adding input device Sleep Button (/dev/input/event3)
[ 4.749] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[ 4.749] (**) Sleep Button: Applying InputClass "system-keyboard"
[ 4.749] (II) Using input driver 'libinput' for 'Sleep Button'
[ 4.749] (**) Sleep Button: always reports core events
[ 4.749] (**) Option "Device" "/dev/input/event3"
[ 4.749] (**) Option "_source" "server/udev"
[ 4.750] (II) event3 - (II) Sleep Button: (II) is tagged by udev as: Keyboard
[ 4.750] (II) event3 - (II) Sleep Button: (II) device is a keyboard
[ 4.750] (II) event3 - (II) Sleep Button: (II) device removed
[ 4.763] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input3/event3"
[ 4.763] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[ 4.763] (**) Option "xkb_model" "pc104"
[ 4.763] (**) Option "xkb_layout" "no"
[ 4.764] (II) event3 - (II) Sleep Button: (II) is tagged by udev as: Keyboard
[ 4.765] (II) event3 - (II) Sleep Button: (II) device is a keyboard
[ 4.767] (II) config/udev: Adding input device Logitech MX Master (/dev/input/event8)
[ 4.767] (**) Logitech MX Master: Applying InputClass "libinput pointer catchall"
[ 4.767] (**) Logitech MX Master: Applying InputClass "libinput keyboard catchall"
[ 4.767] (**) Logitech MX Master: Applying InputClass "system-keyboard"
[ 4.767] (II) Using input driver 'libinput' for 'Logitech MX Master'
[ 4.767] (**) Logitech MX Master: always reports core events
[ 4.767] (**) Option "Device" "/dev/input/event8"
[ 4.767] (**) Option "_source" "server/udev"
[ 4.769] (II) event8 - (II) Logitech MX Master: (II) is tagged by udev as: Keyboard Mouse
[ 4.769] (II) event8 - (II) Logitech MX Master: (II) device is a pointer
[ 4.769] (II) event8 - (II) Logitech MX Master: (II) device is a keyboard
[ 4.769] (II) event8 - (II) Logitech MX Master: (II) device removed
[ 4.783] (II) libinput: Logitech MX Master: needs a virtual subdevice
[ 4.783] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.2/0003:046D:C52B.0003/0003:046D:4060.0004/input/input8/event8"
[ 4.783] (II) XINPUT: Adding extended input device "Logitech MX Master" (type: MOUSE, id 9)
[ 4.784] (**) Option "AccelerationScheme" "none"
[ 4.784] (**) Logitech MX Master: (accel) selected scheme none/0
[ 4.784] (**) Logitech MX Master: (accel) acceleration factor: 2.000
[ 4.784] (**) Logitech MX Master: (accel) acceleration threshold: 4
[ 4.786] (II) event8 - (II) Logitech MX Master: (II) is tagged by udev as: Keyboard Mouse
[ 4.786] (II) event8 - (II) Logitech MX Master: (II) device is a pointer
[ 4.786] (II) event8 - (II) Logitech MX Master: (II) device is a keyboard
[ 4.788] (II) config/udev: Adding input device Logitech MX Master (/dev/input/mouse0)
[ 4.788] (**) Logitech MX Master: Applying InputClass "system-keyboard"
[ 4.788] (II) No input driver specified, ignoring this device.
[ 4.788] (II) This device may have been added with another device file.
[ 4.790] (II) config/udev: Adding input device USB2.0 UVC HD Webcam: USB2.0 UV (/dev/input/event10)
[ 4.790] (**) USB2.0 UVC HD Webcam: USB2.0 UV: Applying InputClass "libinput keyboard catchall"
[ 4.790] (**) USB2.0 UVC HD Webcam: USB2.0 UV: Applying InputClass "system-keyboard"
[ 4.790] (II) Using input driver 'libinput' for 'USB2.0 UVC HD Webcam: USB2.0 UV'
[ 4.790] (**) USB2.0 UVC HD Webcam: USB2.0 UV: always reports core events
[ 4.790] (**) Option "Device" "/dev/input/event10"
[ 4.790] (**) Option "_source" "server/udev"
[ 4.791] (II) event10 - (II) USB2.0 UVC HD Webcam: USB2.0 UV: (II) is tagged by udev as: Keyboard
[ 4.791] (II) event10 - (II) USB2.0 UVC HD Webcam: USB2.0 UV: (II) device is a keyboard
[ 4.791] (II) event10 - (II) USB2.0 UVC HD Webcam: USB2.0 UV: (II) device removed
[ 4.823] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input10/event10"
[ 4.823] (II) XINPUT: Adding extended input device "USB2.0 UVC HD Webcam: USB2.0 UV" (type: KEYBOARD, id 10)
[ 4.823] (**) Option "xkb_model" "pc104"
[ 4.823] (**) Option "xkb_layout" "no"
[ 4.825] (II) event10 - (II) USB2.0 UVC HD Webcam: USB2.0 UV: (II) is tagged by udev as: Keyboard
[ 4.825] (II) event10 - (II) USB2.0 UVC HD Webcam: USB2.0 UV: (II) device is a keyboard
[ 4.826] (II) config/udev: Adding input device Elan Touchpad (/dev/input/event11)
[ 4.827] (**) Elan Touchpad: Applying InputClass "touchpad catchall"
[ 4.827] (**) Elan Touchpad: Applying InputClass "Default clickpad buttons"
[ 4.827] (**) Elan Touchpad: Applying InputClass "libinput touchpad catchall"
[ 4.827] (II) Using input driver 'libinput' for 'Elan Touchpad'
[ 4.827] (**) Elan Touchpad: always reports core events
[ 4.827] (**) Option "Device" "/dev/input/event11"
[ 4.827] (**) Option "_source" "server/udev"
[ 4.828] (II) event11 - (II) Elan Touchpad: (II) is tagged by udev as: Touchpad
[ 4.828] (II) event11 - (II) Elan Touchpad: (II) device is a touchpad
[ 4.828] (II) event11 - (II) Elan Touchpad: (II) device removed
[ 4.855] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-ELAN0100:00/input/input11/event11"
[ 4.855] (II) XINPUT: Adding extended input device "Elan Touchpad" (type: TOUCHPAD, id 11)
[ 4.856] (**) Option "AccelerationScheme" "none"
[ 4.856] (**) Elan Touchpad: (accel) selected scheme none/0
[ 4.856] (**) Elan Touchpad: (accel) acceleration factor: 2.000
[ 4.856] (**) Elan Touchpad: (accel) acceleration threshold: 4
[ 4.857] (II) event11 - (II) Elan Touchpad: (II) is tagged by udev as: Touchpad
[ 4.857] (II) event11 - (II) Elan Touchpad: (II) device is a touchpad
[ 4.859] (II) config/udev: Adding input device Elan Touchpad (/dev/input/mouse1)
[ 4.859] (**) Elan Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[ 4.860] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event5)
[ 4.860] (II) No input driver specified, ignoring this device.
[ 4.860] (II) This device may have been added with another device file.
[ 4.861] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event6)
[ 4.861] (II) No input driver specified, ignoring this device.
[ 4.861] (II) This device may have been added with another device file.
[ 4.862] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event7)
[ 4.862] (II) No input driver specified, ignoring this device.
[ 4.862] (II) This device may have been added with another device file.
[ 4.863] (II) config/udev: Adding input device Asus WMI hotkeys (/dev/input/event9)
[ 4.863] (**) Asus WMI hotkeys: Applying InputClass "libinput keyboard catchall"
[ 4.863] (**) Asus WMI hotkeys: Applying InputClass "system-keyboard"
[ 4.863] (II) Using input driver 'libinput' for 'Asus WMI hotkeys'
[ 4.863] (**) Asus WMI hotkeys: always reports core events
[ 4.863] (**) Option "Device" "/dev/input/event9"
[ 4.863] (**) Option "_source" "server/udev"
[ 4.864] (II) event9 - (II) Asus WMI hotkeys: (II) is tagged by udev as: Keyboard
[ 4.864] (II) event9 - (II) Asus WMI hotkeys: (II) device is a keyboard
[ 4.864] (II) event9 - (II) Asus WMI hotkeys: (II) device removed
[ 4.887] (**) Option "config_info" "udev:/sys/devices/platform/asus-nb-wmi/input/input9/event9"
[ 4.887] (II) XINPUT: Adding extended input device "Asus WMI hotkeys" (type: KEYBOARD, id 12)
[ 4.887] (**) Option "xkb_model" "pc104"
[ 4.887] (**) Option "xkb_layout" "no"
[ 4.888] (II) event9 - (II) Asus WMI hotkeys: (II) is tagged by udev as: Keyboard
[ 4.888] (II) event9 - (II) Asus WMI hotkeys: (II) device is a keyboard
[ 4.890] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[ 4.890] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[ 4.890] (**) AT Translated Set 2 keyboard: Applying InputClass "system-keyboard"
[ 4.890] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[ 4.890] (**) AT Translated Set 2 keyboard: always reports core events
[ 4.890] (**) Option "Device" "/dev/input/event0"
[ 4.890] (**) Option "_source" "server/udev"
[ 4.891] (II) event0 - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
[ 4.891] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
[ 4.891] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device removed
[ 4.903] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[ 4.903] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 13)
[ 4.903] (**) Option "xkb_model" "pc104"
[ 4.903] (**) Option "xkb_layout" "no"
[ 4.905] (II) event0 - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
[ 4.905] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
[ 4.916] (**) Logitech MX Master: Applying InputClass "libinput pointer catchall"
[ 4.916] (**) Logitech MX Master: Applying InputClass "libinput keyboard catchall"
[ 4.916] (**) Logitech MX Master: Applying InputClass "system-keyboard"
[ 4.916] (II) Using input driver 'libinput' for 'Logitech MX Master'
[ 4.916] (**) Logitech MX Master: always reports core events
[ 4.916] (**) Option "Device" "/dev/input/event8"
[ 4.916] (**) Option "_source" "_driver/libinput"
[ 4.916] (II) libinput: Logitech MX Master: is a virtual subdevice
[ 4.916] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.2/0003:046D:C52B.0003/0003:046D:4060.0004/input/input8/event8"
[ 4.916] (II) XINPUT: Adding extended input device "Logitech MX Master" (type: KEYBOARD, id 14)
[ 4.916] (**) Option "xkb_model" "pc104"
[ 4.916] (**) Option "xkb_layout" "no"
[ 4.920] (II) config/udev: Adding input device Elan Touchpad (/dev/input/mouse1)
[ 4.920] (**) Elan Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[ 4.920] (II) config/udev: removing device Elan Touchpad
[ 4.921] (II) event11 - (II) Elan Touchpad: (II) device removed
[ 4.947] (II) UnloadModule: "libinput"
[ 4.947] (II) config/udev: Adding input device Elan Touchpad (/dev/input/event11)
[ 4.948] (**) Elan Touchpad: Applying InputClass "touchpad catchall"
[ 4.948] (**) Elan Touchpad: Applying InputClass "Default clickpad buttons"
[ 4.948] (**) Elan Touchpad: Applying InputClass "libinput touchpad catchall"
[ 4.948] (II) Using input driver 'libinput' for 'Elan Touchpad'
[ 4.948] (**) Elan Touchpad: always reports core events
[ 4.948] (**) Option "Device" "/dev/input/event11"
[ 4.948] (**) Option "_source" "server/udev"
[ 4.949] (II) event11 - (II) Elan Touchpad: (II) is tagged by udev as: Touchpad
[ 4.949] (II) event11 - (II) Elan Touchpad: (II) device is a touchpad
[ 4.949] (II) event11 - (II) Elan Touchpad: (II) device removed
[ 4.975] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-ELAN0100:00/input/input11/event11"
[ 4.975] (II) XINPUT: Adding extended input device "Elan Touchpad" (type: TOUCHPAD, id 11)
[ 4.975] (**) Option "AccelerationScheme" "none"
[ 4.975] (**) Elan Touchpad: (accel) selected scheme none/0
[ 4.975] (**) Elan Touchpad: (accel) acceleration factor: 2.000
[ 4.975] (**) Elan Touchpad: (accel) acceleration threshold: 4
[ 4.977] (II) event11 - (II) Elan Touchpad: (II) is tagged by udev as: Touchpad
[ 4.977] (II) event11 - (II) Elan Touchpad: (II) device is a touchpad

User avatar
KerfufflyKitty
Posts: 40
Joined: Sat Dec 16, 2017 11:56 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 1:22 pm

Code: Select all

[ 4.490] intel: waited 2020 ms for i915.ko driver to load
[ 4.495] (EE) open /dev/dri/card0: No such file or directory

It looks like the kernel failed to load the Intel 915 driver. Could you please post the results of:

Code: Select all

journalctl -b | grep -i -e drm -e video -e i915
As well as:

Code: Select all

journalctl -p 3 -xb

echis
Posts: 9
Joined: Sat Dec 09, 2017 11:09 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 1:48 pm

Here you go:

Code: Select all

journalctl -b | grep -i -e drm -e video -e i915


Dec 17 13:38:35 solus kernel: pci 0000:00:02.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
Dec 17 13:38:36 zenbook kernel: Linux video capture interface: v2.00
Dec 17 13:38:36 zenbook kernel: uvcvideo: Found UVC 1.00 device USB2.0 UVC HD Webcam (064e:9700)
Dec 17 13:38:36 zenbook kernel: uvcvideo 1-5:1.0: Entity type for entity Extension 4 was not initialized!
Dec 17 13:38:36 zenbook kernel: uvcvideo 1-5:1.0: Entity type for entity Processing 2 was not initialized!
Dec 17 13:38:36 zenbook kernel: uvcvideo 1-5:1.0: Entity type for entity Camera 1 was not initialized!
Dec 17 13:38:36 zenbook kernel: usbcore: registered new interface driver uvcvideo
Dec 17 13:38:36 zenbook kernel: USB Video Class driver (1.1.1)
Dec 17 13:38:36 zenbook kernel: snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)
Dec 17 13:38:36 zenbook kernel: snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec
Dec 17 13:38:36 zenbook kernel: snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec
and

Code: Select all

journalctl -p 3 -xb


-- Logs begin at Sat 2017-12-09 23:53:09 CET, end at Sun 2017-12-17 13:44:01 CE>
Dec 17 13:38:37 zenbook bluetoothd[508]: Failed to set mode: Blocked through rf>
Dec 17 13:38:45 zenbook lightdm[640]: gkr-pam: couldn't unlock the login keyrin>
Dec 17 13:38:46 zenbook pulseaudio[791]: [pulseaudio] backend-ofono.c: Failed t>
Dec 17 13:38:46 zenbook pulseaudio[829]: [pulseaudio] pid.c: Daemon already run>
Dec 17 13:38:48 zenbook bluetoothd[508]: Failed to set mode: Blocked through rf>
lines 1-6/6 (END)

User avatar
KerfufflyKitty
Posts: 40
Joined: Sat Dec 16, 2017 11:56 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 2:09 pm

Thanks, I can't really see anything too unusual there. What do:

Code: Select all

lsmod | egrep  'i915'
and

Code: Select all

sudo dmesg | grep -i -e drm -e i915

Have to say? :|

echis
Posts: 9
Joined: Sat Dec 09, 2017 11:09 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 2:39 pm

Code: Select all

lsmod | egrep  'i915'

i915                 1277952  0
i2c_algo_bit           16384  1 i915
drm_kms_helper        122880  1 i915
drm                   315392  2 i915,drm_kms_helper
video                  36864  2 asus_wmi,i915
button                 16384  1 i915

Code: Select all

sudo dmesg | grep -i -e drm -e i915

[    2.118754] snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)
[    2.158161] snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec
[    2.158394] snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec

User avatar
KerfufflyKitty
Posts: 40
Joined: Sat Dec 16, 2017 11:56 pm

Re: Not detecting native resolution options

Sun Dec 17, 2017 3:03 pm

OK, one more idea is to remove the nomodeset option from startup to let the kernel handle setting the mode instead of X.org. If you don't know how to do that, do you know if you are using Grub or clr-boot-manager so we can help you with that? :) (I still haven't installed Solus myself, I'm waiting on a new SSD, so I'm not entirely sure what it's using by default.)

You could also try the linux-lts kernel instead of linux-current if that doesn't work.

Return to “Hardware”