Page 1 of 1

[Fixed] GTX 1070 Ti Support

Posted: Sat Jan 27, 2018 3:44 pm
by mbednarek360
I recently built a new computer, specs: https://pcpartpicker.com/user/mbednarek360/saved/MJJnnQ. The problem is when I went to install the required drivers through DoFlicky, it could not detect the proper driver. I then manually installed the latest driver from the software center, but the machine would not boot properly. I did some research and found that the GTX 1070 Ti requires the 387 driver, but the latest one in the software center is 384. Any ideas on when we will get an update to these drivers for Solus, or if there is another way to safely install them. Any help would be appreciated, Thanks.

Re: GTX 1070 Ti Support

Posted: Sat Jan 27, 2018 3:56 pm
by ycrawler
the latest linux drivers on nvidia.com seems to be 384.111

Re: GTX 1070 Ti Support

Posted: Sat Jan 27, 2018 5:23 pm
by kyrios
387.x is the short lived branch.
384.x is the long lived branch.

Solus only offers the long lived nvidia drivers. These drivers support your gpu according to nvidia.

Re: GTX 1070 Ti Support

Posted: Sun Jan 28, 2018 12:52 am
by mbednarek360
Thanks, It turns out it wouldn't post because I installed nvidia-340-glx-driver and i needed to install nvidia-glx-driver-current. Although DoFlicky still didn't detect my gpu. Everything is now working as intended.

Re: GTX 1070 Ti Support

Posted: Sun Jan 28, 2018 11:04 am
by kyrios
mbednarek360 wrote:
Sun Jan 28, 2018 12:52 am
Thanks, It turns out it wouldn't post because I installed nvidia-340-glx-driver and i needed to install nvidia-glx-driver-current. Although DoFlicky still didn't detect my gpu. Everything is now working as intended.
DoFlicky will die into fire soon as a punishment ;)