Posts: 1
Joined: Sun Mar 04, 2018 8:04 pm

Broadcom SDIO wifi not working

Sun Mar 04, 2018 8:21 pm

Hello, total noob here!!!
Today I installed Solus. everything great, just wi-fi doesn't work, ethernet does.
I've tried various command to identify my network device, but none of those found it.
So, after some search i found in the BIOS setup an option to configure wi-fi where I can switch it from AP6212 to AP6255.
Googling that returned a broadcom SDIO wifi card. Installed broadcom drivers from eopkg, also installed brcmfmac firmware, but still doesn't work.
At this point I'm asking help to you more experienced people, as I don't know what to do more.

User avatar
Posts: 6
Joined: Sun Mar 25, 2018 9:29 am

Re: Broadcom SDIO wifi not working

Sun Mar 25, 2018 9:55 am

Solus comes with a command line utility called inxi. Open the terminal and type:

Code: Select all

inxi -n
Just in the Return/Enter key after entering the command. That should give you info about all of your network cards; e.g. WiFi, ethernet.

For a possible fix to get your Broadcom WiFi working, checkout the following:


Return to “Hardware”