Posts: 3
Joined: Sun Jan 07, 2018 5:16 am

Installing Solus -- The adventures of a Windows 7 fan boy

Sun Jan 07, 2018 5:23 am

My specs
  • msi B350 pc mate
  • AMD Ryzen 7 1800x
  • Radeon R9 390x
  • Crucial 16GB (2x8GB) DDR4 2400MHz CL16 Ballistix Sport
  • Samsung 830 (128 GB)

Chapter 1 -- Boot and install

The very first issue I encountered was not being able to boot up Solus live from my flashdrive, but instead getting an endless wall of text.
Since the Solus irc and forum was too busy lurking, I decided to look for solutions at other forums, and found a solution at ubuntuask. They suggested to edit the boot settings
from this GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash"
to this GRUB_CMDLINE_LINUX_DEFAULT = "quiet iommu=soft splash"
(This solution is NOT recommended. Instead use the alternative solution further down!)

This did work, and I was able to boot Solus live and install it on my SSD. However, this solution proved to be quite bad, as I will come back to this later.

After installing Solus I booted it up from my SSD, but once again I needed to add the "iommu=soft" in the grub settings before booting up, wich can be done simply by pressing E in the boot screen, and then edit the settings. I logged in to the system and tried it out. It did not take long before i discovered that my system sucked donkey balls. In-game performance was extremely laggy, and the desktop would also randomly freeze for a split second.
Howerver, after doing some digging around, I tried changing the grub settings again
from this GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash"
to this GRUB_CMDLINE_LINUX_DEFAULT = "quiet amd_iommu=off splash"
(This solution is what I recommend)

The difference was night and day. No more in-game lag or random freezes. Don't ask me what this shit does, but it works.


I still have have few problems. I will report in when I have found solutions. Feel free to help out.

My fix list
  • Shitty microphone quality (Antlion ModMic 4)
    I can't talk to my friends on discord, or any voip, because my microphone sounds like shit since I installed Solus. I will try fiddling with pulseaudio. Still works fine on windows, definetly not a hardware issue.
  • Save grub settings
    So I don't have to change them every time before boot. I am getting "syntax error on row 4" every time I try to save. I will try this ... solus-boot

I hope this thread can help other windows emigrants over to the enlightened side.

Return to “Installation”