Posts: 2
Joined: Wed Jun 06, 2018 11:47 pm

ASUS Laptop, No Sound, what's step one?

Thu Jun 07, 2018 12:37 am


I'm a Newbie to linux. I first installed Solus on a 3 year old MacMini about 4 months ago and was pleasantly surprised at how easy it was to install, and how well everything worked. And best of all, Solus made the MacMini perform so much better than MacOS.

So with that great experience under my belt, I decided to upgrade my 13 year old MacBook to a new ASUS UX430 Laptop, and install Solus (Budgie). The installation went fine, and overall Solus is working great, but no audio.

I'm finding random bits and pieces online as to what may or may not be the problem and what may or may not help fix the problem. But no definitive solution, as far as I can tell.

So far I've run 'alsamixer' and I can select the 'Sound Card' : 'HDA Intel PCH'. Everything seems to be fine with the mixer. If I plug in headphones, the mixer automatically mutes the speakers and turns on the headphone output. But no sound in either the headphones or speakers.

My question: As a Newbie, instead of randomly trying things (that may make things worse), what 'should' be my first step in tackling this issue?


Posts: 8
Joined: Fri Jun 08, 2018 6:56 pm

Re: ASUS Laptop, No Sound, what's step one?

Fri Jun 08, 2018 7:05 pm

Download SOLUS in a pendrive again, plug it in your laptop and boot into the usb. Test the sound of Solus. If there is sound, just resintall the system. If there is no sound, try to find another solution

Posts: 154
Joined: Tue Nov 29, 2016 6:43 am

Re: ASUS Laptop, No Sounds, what's step one?

Sat Jun 09, 2018 2:46 am

I would suggest that if previewing Solus in Live Mode has no sound issues - - drop to a terminal window (ctrl+alt+t) and run Alsamixer again. This time, note the settings carefully and jot down the values.

It's been YEARS since I've had sound issues in Linux, but I recall if you see "MM" for a channel, it means it is muted. To unmute, use tab to select the channel and press "m" to unmute, then use the up and down arrow keys to adjust the volume. Often, the PCM channel is the culprit.

A good idea is to go to youtube and watch several of the alsamixer tutorials. This is important especially for multi chip sound systems.

Posts: 2
Joined: Wed Jun 06, 2018 11:47 pm

Re: ASUS Laptop, No Sound, what's step one?

Tue Jun 12, 2018 2:47 am

Thank you both for your suggestions. And sorry for the late reply, I had a busy work weekend.

My sound now suddenly seems to be working?!?

When I had a moment, I was going to try the thumb drive and re-install suggestions. Because I remember having an issue with 'updating' the system right after first install, where it seemed to take a very long time, but eventually it just said, 'done, everything updated'. It seemed odd at the time, compared to the updates I've done on my home computer (the MacMini), which seemed fast/normal.

Anyways, yesterday, there was a notification saying I should update for security, and I thought maybe there would be some other updates that might magically take the place of a reinstall. So I started the update, but again it was taking a very long time to figure out what the updates were.

While that was happening, I was downloading some pictures, that had been synch'd from from home computer. I don't usually take movies, but there were a couple of movie clips in with my photos. I went to audition a clip, I guess with the default Gnome MPV, and there was sound!

I doubt it was the updating that changed things, because it still hadn't got to the point where it shows what I want updated, let alone start the updating. So I assume that for some reason the Gnome MPV unstuck the audio?

Then I tried a YouTube video, and the sound worked fine. One of the reasons for switching to linux is that I mainly use SoX for audio work. And Sox now worked fine at playing audio. Both YouTube and Sox didn't work a few days ago. 'Sound Settings : Test speakers' still doesn't seem to work. But as far as I can tell, sound works everywhere now.

Anyways, thanks for the help. I don't know if I'm supposed to mark this as 'solved', as I don't really know what I did that fixed it? Maybe if someone else has a similar problem, then "maybe" playing some sound with Gnome MPV will switch on the sound. But I can't test the theory?

Thanks again.

Return to “Hardware”