SOLUS_INVICTUS
Posts: 29
Joined: Sun Jun 10, 2018 2:05 pm

PowerShell installation : Only binary installation ? [SOLVED]

Sat Jun 16, 2018 11:36 pm

Hello,

Bash is enough ( and easier ) for me on Linux but I need also PowerShell on Solus :
Only for trainnig purposes on scripting & programming for my job ... without having to use Windows 10 hugly :) or CentOS7 a little too professional for this purpose...

My PCs & NoteBook are in Trial Boot : I have Powershell installed on all my Windows 10, FEDORA28 & CENTOS7 partitions...

But,
As I'm systematically replacing on all my PCs FEDORA28 by SOLUS ( so better looking & working and also so lighter ).
I need that Powershell runs perfectly on Solus... to have not only fun with Solus but to also to be able to use Solus for Day To Day task and to follow some training courses and been able to make a lot of tests.


I've installed PowerShell 6 on Solus using the Binary Archives as explained at :
https://docs.microsoft.com/en-us/powers ... -archives

Code: Select all

# Download the powershell '.tar.gz' archive
curl -L -o /tmp/powershell.tar.gz https://github.com/PowerShell/PowerShell/releases/download/v6.0.2/powershell-6.0.2-linux-x64.tar.gz

# Create the target folder where powershell will be placed
sudo mkdir -p /opt/microsoft/powershell/6.0.2

# Expand powershell to the target folder
sudo tar zxf /tmp/powershell.tar.gz -C /opt/microsoft/powershell/6.0.2

# Set execute permissions
sudo chmod +x /opt/microsoft/powershell/6.0.2/pwsh

# Create the symbolic link that points to pwsh
sudo ln -s /opt/microsoft/powershell/6.0.2/pwsh /usr/bin/pwsh




PowerShell seems working perfectly well on Solus :
  • CODE :
    user~ $ pwsh
    PowerShell v6.0.2
    Copyright (c) Microsoft Corporation. All rights reserved.

    https://aka.ms/pscore6-docs
    Type 'help' to get help.

And I dispose of all the rights on PoH
  • CODE :
    PS /home/user> Get-ExecutionPolicy
    Unrestricted

The Help/Intellisense using tab works perfectly :
  • CODE :
    PS /home/user> Up
    Update-ConfigurationDocumentRef Update-Help Update-ModuleVersion upmo Update-ConfigurationErrorCount Update-LocalConfigManager Update-Script Update-DependsOn Update-Module Update-ScriptFileInfo Update-FormatData Update-ModuleManifest Update-TypeData


But if I ask to update the help : Nothing happens
  • CODE :
    PS /home/user> Update-Help
    PS /home/user>

Is there another solution than binary installation of PowerShell, to be sure that everything is running OK with PoH on Solus ?

Best regards.
Last edited by SOLUS_INVICTUS on Sat Jul 14, 2018 8:47 pm, edited 1 time in total.

SOLUS_INVICTUS
Posts: 29
Joined: Sun Jun 10, 2018 2:05 pm

Re: PowerShell installation : Only binary installation ?

Wed Jun 27, 2018 7:41 pm

Hello,

After triple check :

PowerShell & PowerShell's Help Update runs perfectly well on Solus...

For PowerShell's Help Update,
I just need :
  • CODE :
    user~ $ sudo pwsh
    PS /home/user> Update-Help

Instead of :
  • CODE :
    user~ $ pwsh
    PS /home/user> Update-Help
PowerShell is unrestricted but it seems not enough for writing updates in Linux.

As there is no issues with PowerShell's installation on Solus.

This post can be solved.

Best regards

clauded
Posts: 55
Joined: Thu Jan 05, 2017 10:49 pm

Re: PowerShell installation : Only binary installation ?

Tue Jul 10, 2018 3:15 am

Please edit the title of your subject and add [SOLVED] to it. Thanks.

Return to “Installation”