shorty_06
Posts: 19
Joined: Sat Dec 03, 2016 9:31 pm

How to Disable Mouse Acceleration

Sun Dec 04, 2016 1:34 am

Disabling mouse acceleration simply requires creating a new file at:

Code: Select all

/etc/X11/xorg.conf.d/50-mouse-acceleration.conf
With the following inside it:

Code: Select all

Section "InputClass"
    Identifier "My Mouse"
    Driver "libinput"
    MatchIsPointer "yes"
    Option "AccelProfile" "flat"
EndSection
You don't need to change anything, "My Mouse" is just an arbitrary name.

After you have done this restart, and mouse acceleration should be disabled.

You can test if it works properly by moving your mouse to the very left of your screen then placing it against your keyboard. Flick your mouse quickly to the right and then slowly drag it back. It should reach the edge of the screen as it touches your keyboard again.

SamDyer
Posts: 41
Joined: Sun Dec 25, 2016 10:49 am

Re: How to Disable Mouse Acceleration

Sun Dec 25, 2016 11:18 am

Thanks for posting this , mouse acceleration annoys the crap out of me and would rather it always moved at a constant speed.

User avatar
Justin
Development Team
Posts: 3617
Joined: Mon Jul 28, 2014 10:42 am
Location: Adelaide, Australia
Contact: Website Google+ Twitter

Re: How to Disable Mouse Acceleration

Tue Jan 03, 2017 5:25 am

Thanks for the HowTo!

frost
Posts: 2
Joined: Mon Nov 20, 2017 8:33 pm

Re: How to Disable Mouse Acceleration

Mon Nov 20, 2017 8:45 pm

hi. I switched to solus from windows today and I absolutely love it so far but this acceleration problem I have might be a dealbreaker. =(
Neither the suggestion here nor the one i found online

Code: Select all

Section "InputClass"
    Identifier "My Mouse"
    MatchIsPointer "yes"
    Option "AccelerationProfile" "-1"
    Option "AccelerationScheme" "none"
    Option "AccelSpeed" "-1"
EndSection
seem to work.

Since I'm a passionate CS:GO player (LE) i need the acceleration to be turned off to hit anything properly..

Has anything changed since this tutorial was made? I'm sure i didn't do anything wrong.

regarts

frost
Posts: 2
Joined: Mon Nov 20, 2017 8:33 pm

Re: How to Disable Mouse Acceleration

Mon Nov 20, 2017 8:49 pm

Hi.
Neither the suggestion in this thread nor the one i found online

Code: Select all

Section "InputClass"
    Identifier "My Mouse"
    MatchIsPointer "yes"
    Option "AccelerationProfile" "-1"
    Option "AccelerationScheme" "none"
    Option "AccelSpeed" "-1"
EndSection
seem to work.

Has anything changed since this tutorial was made? I'm pretty sure I din't do anything wrong.

regarts

Jman
Posts: 5
Joined: Sat Jun 09, 2018 2:54 pm

Re: How to Disable Mouse Acceleration

Sat Jun 09, 2018 2:57 pm

Hello, I also have have problems disabling mouse acceleration. I have tried the solutions above and rebooted the computer, but the mouse still accelerates.

User avatar
ycrawler
Posts: 141
Joined: Thu Aug 10, 2017 8:23 pm

Re: How to Disable Mouse Acceleration

Sat Jun 09, 2018 6:50 pm

can be switched off in gnome tweaks now, and then adjust the speed in gnome settings

Jman
Posts: 5
Joined: Sat Jun 09, 2018 2:54 pm

Re: How to Disable Mouse Acceleration

Sun Jun 10, 2018 4:17 pm

ycrawler wrote:
Sat Jun 09, 2018 6:50 pm
can be switched off in gnome tweaks now, and then adjust the speed in gnome settings
That worked perfectly! Many thanks!

I installed "gnome-tweaks"
Opened "Tweaks"
Changed "Acceleration profile" to "Flat" Below the settings for "Keyboard & mouse"

Return to “Tutorials”